NSX-V Lab Setup

Intro

Welcome to Part 1 of the NSX-V Lab Series. In the previous post, we covered the introduction to the NSX-V lab series.
In this post we’ll cover briefly how my lab is setup from the physical to the virtual to the nested virtual.

Physical Environment

Hosts

I have three physical hosts, these are Dell Poweredge T20 Servers they are about 2-3 years old and each has a single four core Intel(R) Xeon(R) CPU E3-1225 v3 @ 3.20GHz . Each host has 32 GB of RAM and a single onboard 1GB NIC, additionally each host also has a 4 port 1GB NIC card.
So the hosts are not particularly new and not particularly beefy but they do run my lab just fine despite the CPU, RAM and Network limitations. I’m going to have to upgrade them though in a year or two as they will eventually be too old to run the newer software.
The physical adapters on the hosts are configured as per the below screenshot.
I’ve kept the management and storage on local vSwitches for simplicity, Management on vSwitch0 and Storage on vSwitch 1.
While VMNIC’s 2 and 3 are connected to the Lab-vDS

Switch

I currently have a single physical switch which is a 24 port Cisco 3750 G I have the following VLANs configured.
The only VLANs I’ll be using for the NSX-V lab are VLAN10 which is for Site A management, VLAN15 which is Site B Management VLAN30 which is the storage network VLAN 50 which is the overlay network for Site A and VLAN 55 which is the overlay network for Site B.
Uplink VLANs 60, 65 and 70, 75 for the Edge Services Gateways will only be on virtual routers but the switch port will allow the VLANs on the trunk.

interface Vlan10
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan15
 ip address 192.168.15.1 255.255.255.0
!
interface Vlan30
 ip address 192.168.30.1 255.255.255.0
!
interface Vlan50
ip address 10.50.1.1 255.255.255.0
!
interface Vlan55
ip address 10.55.1.1 255.255.255.0

Each host port is trunked with the following configuration.

interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,15,30,50,55,60,65,70,75
switchport mode trunk
spanning-tree portfast trunk
spanning-tree bpduguard enable

Storage

For storage I’m using a Synology NAS with spinning disks over the 1GB network with two datastores configured for the lab, again it’s not the fastest in the world but since I don’t really run many client VM’s and I have no intention of running Horizon it does the job OK.

Virtual Environment

Hosts

I have twelve nested ESXi 6.7 hosts running on the physical hosts these are for site A VComp01, VComp02, VComp03 and VEdge01, VEdge02 and VEdge03.
For Site B SiteBVComp01, SiteBVComp02, SiteBVComp03 and SiteBVEdge01, SiteBVEdge02 and SiteBVEdge03.
Each host has 4 CPUs and 16GB of RAM.
Each host has 4 network adapters, NIC 1 on Site A hosts is connected to Management-vDS which is for Management for Site B hosts it’s SiteB-MGMT. Nic 2 and 3 are connect to the Nested-LAN portgroup which is a VLAN trunk and NIC 4 is connected to VM_iSCSI for storage.

VMs

On the physical hosts I am running the following VM’s.
LabAD01 which is the active directory server.
vCenter1 which is you guessed it the vCenter for site A 😉
vCenter2 which is the vCenter for site B
Lab-router-XG and Lab-router-XG02 which will be our two virtual routers for site A to which the Edge Services Gateways will be connected.
Lab-router-XGB and Lab-router-XGB02 which will be our two virtual routers for site B to which the Edge Services Gateways will be connected.
Finally once we get into the deployment I’ll also run NSXVMan01 and NSXVMan02 which will be our NSX-V managers.

Clusters

vCenter1

vCenter1 runs three clusters.
Lab – this houses our three physical hosts.
VComp – Houses our nested Compute hosts
VEdge – Houses our nested Edge hosts

vCenter2

Clusters

vCenter2 runs two clusters.
SiteBvComp – Houses our nested Compute hosts
SiteBvEdge – Houses our nested Edge hosts

Network

On the lab cluster I run a vDS called Lab-vDS which has the Management-vDS, SiteB-MGMT and Nested-LAN port groups.

Settings for the Nested-LAN portgroup set to VLAN trunking

On Site A I also have two vDS’s configured one for the Compute and one for the Edge cluster.
The three nested Compute hosts are added to the compute vDS which runs the portgroup for the VTEPs and the logical switches.

The second vDS is configured on the Edge cluster, the three nested Edge hosts are added to this vDS which runs the portgroup for the VTEPs the logical switches and the Uplink VLANs 60 and 70.

Site B will have the same configuration as Site A just with the Site B VLAN’s.

Nested Environment

The nested environment will have our Edge Gateways running on the Edge clusters and test apps running on the compute clusters.

That’s about it for the lab setup. now let’s start our build.
NSX-V Lab Part:2 – NSX-V Lab: 6.4.5 Install, OVA Deployment of NSX-V Manager

Leave a Reply

Your email address will not be published.