NSX-T Lab Setup

Intro

Welcome to Part 1 of the NSX-T Lab Series. In the previous post, we covered the introduction to the NSX-T lab series.
In this post we’ll cover briefly how my lab is setup from the physical to the virtual to the nested virtual.

Physical Environment

Hosts

I have three physical hosts, these are Dell Poweredge T20 Servers they are about 2-3 years old and each has a single four core Intel(R) Xeon(R) CPU E3-1225 v3 @ 3.20GHz . Each host has 32 GB of RAM and a single onboard 1GB NIC, additionally each host also has a 4 port 1GB NIC card.
So the hosts are not particularly new and not particularly beefy but they do run my lab just fine despite the CPU, RAM and Network limitations. I’m going to have to upgrade them though in a year or two as they will eventually be too old to run the newer software.
The physical adapters on the hosts are configured as per the below screenshot.
I’ve kept the management and storage on local vSwitches for simplicity, Management on vSwitch0 and Storage on vSwitch 1.
While VMNIC’s 2 and 3 are connected to the Lab-vDS

Switch

I currently have a single physical switch which is a 24 port Cisco 3750 G I have the following VLANs configured.
The only VLANs I’ll be using for the NSX-T lab are VLAN10 which is for management, VLAN30 which is the storage network and VLAN 150 which is the overlay network. Uplink VLANs 160 and 170 for the Edge nodes will only be on virtual routers.

interface Vlan10
 ip address 192.168.10.1 255.255.255.0
!
interface Vlan30
 ip address 192.168.30.1 255.255.255.0
!
interface Vlan150
 ip address 10.150.1.1 255.255.255.0

Each host port is trunked with the following configuration.

interface GigabitEthernet1/0/1
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1,10,30,150,160,170
switchport mode trunk
spanning-tree portfast trunk
spanning-tree bpduguard enable

Storage

For storage I’m using a Synology NAS with spinning disks over the 1GB network with two datastores configured for the lab, again it’s not the fastest in the world but since I don’t really run many client VM’s and I have no intention of running Horizon it does the job OK.

Virtual Environment

Hosts

I have six nested ESXi 6.7 hosts running on the physical hosts these are Comp01, Comp02, Comp03 and Edge01, Edge02 and Edge03.
Each host has 4 CPUs and 16GB of RAM.
Each host has 4 network adapters, NIC 1 is connected to Management-vDS which is for Management. Nic 2 and 3 are connect to the Nested-LAN portgroup which is a VLAN trunk and NIC 4 is connected to VM_iSCSI for storage.

VMs

On the physical hosts I am running the following VM’s.
LabAD01 which is the active directory server.
vCenter1 which is you guessed it the vCenter 😉
Lab-router-XG and Lab-router-XG02 which will be our two virtual routers to which the Edge nodes will be connected.
Finally once we get into the deployment I’ll also run NSXTMan01 which will be our NSX-T manager

vCenter1

Clusters

vCenter1 runs three clusters.
Lab – this houses our three physical hosts.
Comp – Houses our nested Compute hosts
Edge – Houses our nested Edge hosts

Network

On the lab cluster I run a vDS called Lab-vDS which has the Management-vDS and Nested-LAN port groups.

Settings for the Nested-LAN portgroup set to VLAN trunking

I also have a second vDS configured on the Edge cluster.
The three nested Edge hosts are added to this vDS which runs the portgroups Edge-Mgmt the Overlay VLAN-150 and the two uplinks VLAN’s 160 and 170

Nested Environment

The nested environment will have our Edge nodes running on the Edge cluster and a test app running on the compute cluster.
The compute cluster will not have a vDS but instead will be prepared for NSX-T and will have an N-VDS configured for the overlay using VMNIC1 and 2.
Here’s how it will look after the build.

That’s about it for the lab setup. now lets start our build.
NSX-T Lab Part:2 – 2.4 Install, OVA Deployment of NSX-T Manager

Leave a Reply

Your email address will not be published.